Why do I get a message that I have to update my Android app?

Because of recent updates, Android users will be prompted to update to our most recent app version.

To continue  watching, you'll need to update the app. To do so, visit the Play Store and search DramaFever. Click "Update" to install the latest version.

Unfortunately, we no longer support versions of Android below 4.0.
 
Have more questions? Submit a request
Powered by Zendesk