The video won't start or load

If the video does not load and is just a black screen and you're using Internet Explorer, please upgrade to the most recent version of your browser or try accessing the site from another browser on your computer.

If you have general questions about the video player, please see our FAQs here:

 
1. Why does the quality on the video player keep changing or why is the video buffering? 
2. How do I change the subtitle style? 
3. How do I turn subtitles on or off? 
 
If the video is not loading for you, please try the following troubleshooting tips:
 
1. Clear your cookies. You can learn how to do that in your browser by clicking here
 
2. Upgrade your browser. We recommend always running the most up to date version for the smoothest experience.
 
3. Make sure you have JavaScript and Cookies enabled on your browser. You can confirm that by visiting supportdetails.com. You can find instructions for enabling your cookies by clicking here or enabling JavaScript by clicking here
 
4. If you're using Internet Explorer, please make sure you have the latest version and that you don't have Compatibility Mode enabled. If you are using Windows 8 and Internet Explorer version 10, please upgrade to the most recent version of IE or try another browser on your device.

5. Make sure you have a strong enough connection. You can test this at speedtest.net. Also check that you have a ping speed below 50ms with no packet loss. You can check your ping speed here.
Have more questions? Submit a request
Powered by Zendesk